Mikrotik firewall povezava subneta na gateway

Internet, wi-fi, baby kontrola,...

Moderator: S53AL

Mikrotik firewall povezava subneta na gateway

OdgovorNapisal/-a s54mtb » 11 Jun 2019, 23:37

Imam tri porte:
eth1 je uplink preko wifi povezave (wifi link na naslovu 44.150.168.2), subnet 44.150.168.0/27 (dhcp je na 44.150.168.1 in se relaya na eth1)
eth2 je subnet 44.150.168.32/28 (+ ima svoj lokalni dhcp)
eth3 je subnet 44.150.168.48/28 (+ ima svoj lokalni dhcp)


tole je konfiguracija za zgoraj omenjeno:
Koda: Izberi vse
/interface bridge
add name=bridge1-s54mtb
add name=bridge2-nbp
add name=bridge3-miklavz-Local
/interface ethernet
set [ find default-name=ether1 ] name=ether1-s54mtb
set [ find default-name=ether2 ] name=ether2-nbp
set [ find default-name=ether3 ] name=ether3-miklavz
/ip pool
add name=pool-NBP ranges=44.150.168.41-44.150.168.46
add name=pool-miklavzLocal ranges=44.150.168.53-44.150.168.62
/ip dhcp-server
add address-pool=pool-NBP authoritative=after-2sec-delay disabled=no \
    interface=bridge2-nbp name=server1-nbp
add address-pool=pool-miklavzLocal disabled=no interface=\
    bridge3-miklavz-Local name=server2-miklavzLocal
/interface bridge port
add bridge=bridge1-s54mtb interface=ether1-s54mtb
add bridge=bridge2-nbp interface=ether2-nbp
add bridge=bridge3-miklavz-Local interface=ether3-miklavz
/ip address
add address=44.150.168.13/27 interface=bridge1-s54mtb network=44.150.168.0
add address=44.150.168.33/28 interface=bridge2-nbp network=44.150.168.32
add address=44.150.168.49/28 interface=bridge3-miklavz-Local network=\
    44.150.168.48
/ip dhcp-relay
add dhcp-server=44.150.168.1 disabled=no interface=ether1-s54mtb name=\
    relay-from.1
/ip dhcp-server network
add address=44.150.168.32/28 dns-server=44.150.168.2 gateway=44.150.168.2 \
    netmask=28
/ip dns
set servers=44.150.168.1,44.150.168.2
/ip route
add distance=1 gateway=44.150.168.2
/system clock
set time-zone-name=Europe/Ljubljana
/system identity
set name=mtik-s54mtb-miklavz


Kako (s firewallom?) povežem bridge2-nbp in bridge3-miklavz-Local preko gatewaya 44.150.168.2 tako, da ostanejo med sabo izolirani.
Making raw materials do something useful since 1969.
Uporabniški avatar
s54mtb
 
Prispevkov: 9474
Pridružen: 15 Jan 2015, 01:10
Zahvalil se je: 1288 krat
Prejel zahvalo: 3196 krat
Uporabnika povabil: Vrtni palček
Število neizkoriščenih povabil: 178

Re: Mikrotik firewall povezava subneta na gateway

OdgovorNapisal/-a Carko » 12 Jun 2019, 01:35

Pišem na pamet, ampak bi moralo biti to to:

1. Na ether1-s54mtb vklopi proxy-arp
2. V firewall dodaj

Koda: Izberi vse
ip firewall filter add chain=forward in-interface=bridge2-nbp out-interface=bridge3-miklavz-Local action=drop
ip firewall filter add chain=forward out-interface=bridge2-nbp in-interface=bridge3-miklavz-Local action=drop


PS. Če imaš samo en interface v vsakem bridge-u, potem bridge-ov sploh ne rabiš in lahko operiraš enako direkt z interface-i.
Carko
 
Prispevkov: 1928
Pridružen: 10 Jan 2015, 01:46
Zahvalil se je: 122 krat
Prejel zahvalo: 449 krat
Uporabnika povabil: Vrtni palček
Število neizkoriščenih povabil: 115

Re: Mikrotik firewall povezava subneta na gateway

OdgovorNapisal/-a s54mtb » 12 Jun 2019, 01:55

Carko je napisal/-a:Pišem na pamet, ampak bi moralo biti to to:

1. Na ether1-s54mtb vklopi proxy-arp
2. V firewall dodaj

Koda: Izberi vse
ip firewall filter add chain=forward in-interface=bridge2-nbp out-interface=bridge3-miklavz-Local action=drop
ip firewall filter add chain=forward out-interface=bridge2-nbp in-interface=bridge3-miklavz-Local action=drop


PS. Če imaš samo en interface v vsakem bridge-u, potem bridge-ov sploh ne rabiš in lahko operiraš enako direkt z interface-i.


Hvala.

Bom preveril.


Konfiguracijo pripravljam na malem rutrčku, ki ga bo zamenjal večji, kjer bo več portov. So pa še tuneli v bridge-u, ki niso prikazani v gornji konfiguraciji.
Making raw materials do something useful since 1969.
Uporabniški avatar
s54mtb
 
Prispevkov: 9474
Pridružen: 15 Jan 2015, 01:10
Zahvalil se je: 1288 krat
Prejel zahvalo: 3196 krat
Uporabnika povabil: Vrtni palček
Število neizkoriščenih povabil: 178


Vrni se na Komunikacije

Kdo je na strani

Po forumu brska: 0 registriranih uporabnikov in 1 gost